using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[$|€|£] [\d]{1,}[.,](\d{2})[ ][A-Z]{3}";
string input = @"1
2
3
$ 1344.00 USD
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}