$re = '/[$|€|£] [\d]{1,}[.,](\d{2})[ ][A-Z]{3}/m';
$str = '1
2
3
$ 1344.00 USD
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);