// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[$|€|£] [\d]{1,}[.,](\d{2})[ ][A-Z]{3}").unwrap();
let string = "1
2
3
$ 1344.00 USD
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}