package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[$|€|£] [\d]{1,}[.,](\d{2})[ ][A-Z]{3}`)
var str = `1
2
3
$ 1344.00 USD
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}