#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^A01H1\d{1,2}(?!\d)"
Local $sString = "A01H100" & @CRLF & _
"A01H140" & @CRLF & _
"A01H110" & @CRLF & _
"A01H100more" & @CRLF & _
"A01H140-text" & @CRLF & _
"A01H110...here"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")