import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^A01H1\\d{1,2}(?!\\d)";
final String string = "A01H100\n"
+ "A01H140\n"
+ "A01H110\n"
+ "A01H100more\n"
+ "A01H140-text\n"
+ "A01H110...here";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}