re = /^A01H1\d{1,2}(?!\d)/m
str = 'A01H100
A01H140
A01H110
A01H100more
A01H140-text
A01H110...here'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end