# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d{3}\B\K/./gm;t' <<< "12345678911
111222333444
11222333444"