$re = '/\d{3}\B\K/m';
$str = '12345678911
111222333444
11222333444';
$subst = ".";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;