const regex = /\d{3}\B\K/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{3}\\B\\K', 'gm')
const str = `12345678911
111222333444
11222333444`;
const subst = `.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);