using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"typedef enum\s*{([^;*]+)}rba_EcuSecu";
string input = @"typedef enum
{
CONTEXT_0 = 0,
CONTEXT_1 = 1,
CONTEXT_2 = 2,
CONTEXT_3 = 7,
}aes_context_e;
typedef enum
{
CIPHER_MATCH_E = 0,
CIPHER_NOT_MATCHED_E = 1,
CIPHER_MATCH_NOT_POSSIBLE_E = 3,
CIPHER_MATCHED_TAG_NOT_MATCHED = 5,
CIPHER_NOT_MATCHED_TAG_MATCHED = 6,
}rba_EcuSecu_AES_CipherChk_e;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}