use strict;
my $str = 'typedef enum
{
CONTEXT_0 = 0,
CONTEXT_1 = 1,
CONTEXT_2 = 2,
CONTEXT_3 = 7,
}aes_context_e;
typedef enum
{
CIPHER_MATCH_E = 0,
CIPHER_NOT_MATCHED_E = 1,
CIPHER_MATCH_NOT_POSSIBLE_E = 3,
CIPHER_MATCHED_TAG_NOT_MATCHED = 5,
CIPHER_NOT_MATCHED_TAG_MATCHED = 6,
}rba_EcuSecu_AES_CipherChk_e;';
my $regex = qr/typedef enum\s*{([^;*]+)}rba_EcuSecu/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}