const regex = new RegExp('typedef enum\\s*{([^;*]+)}rba_EcuSecu', 'mg')
const str = `typedef enum
{
CONTEXT_0 = 0,
CONTEXT_1 = 1,
CONTEXT_2 = 2,
CONTEXT_3 = 7,
}aes_context_e;
typedef enum
{
CIPHER_MATCH_E = 0,
CIPHER_NOT_MATCHED_E = 1,
CIPHER_MATCH_NOT_POSSIBLE_E = 3,
CIPHER_MATCHED_TAG_NOT_MATCHED = 5,
CIPHER_NOT_MATCHED_TAG_MATCHED = 6,
}rba_EcuSecu_AES_CipherChk_e;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}