using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?P<country>[A-Za-z]+(?:,? [A-Za-z]+)+)\b";
string input = @"New York, US
California, United States of America (USA)
Massachusetts, United States of America(USA)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}