// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?P<country>[A-Za-z]+(?:,? [A-Za-z]+)+)\b").unwrap();
let string = "New York, US
California, United States of America (USA)
Massachusetts, United States of America(USA)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}