package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?P<country>[A-Za-z]+(?:,? [A-Za-z]+)+)\b`)
var str = `New York, US
California, United States of America (USA)
Massachusetts, United States of America(USA)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}