re = /\b(?P<country>[A-Za-z]+(?:,? [A-Za-z]+)+)\b/m
str = 'New York, US
California, United States of America (USA)
Massachusetts, United States of America(USA)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end