re = /\$\d+(?![0-9.])/m
str = '5x Item C $2.5x5, $2.50x1
1 Book $2.55
1x Table $2.59
2x Item A $2000.5x2, 10x Item B $0.5x10
1x Test $2.513, 5x Pear $100x5
$1.430
$1.50
$1.55
10x Tee $0.5x10
50x SSS $6.5x50
$2.5, $50'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end