import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)(?<name>\\w+)(?=(?:[^|]*\\|){3}\\s*\\b(?<value>[0-9]+(?:\\.[0-9]+)?)\\s+(?<unit>[^0-9\\s]\\S*))";
final String string = "[1] weight | width | depth | 5.0 kg | 6.0 mm^2 | 10.12 cm^3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}