re = /(?<!\S)(?<name>\w+)(?=(?:[^|]*\|){3}\s*\b(?<value>[0-9]+(?:\.[0-9]+)?)\s+(?<unit>[^0-9\s]\S*))/m
str = '[1] weight | width | depth | 5.0 kg | 6.0 mm^2 | 10.12 cm^3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end