const regex = new RegExp('(?<!\\S)(?<name>\\w+)(?=(?:[^|]*\\|){3}\\s*\\b(?<value>[0-9]+(?:\\.[0-9]+)?)\\s+(?<unit>[^0-9\\s]\\S*))', 'gm')
const str = `[1] weight | width | depth | 5.0 kg | 6.0 mm^2 | 10.12 cm^3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}