$re = '/(?<!\S)(?<name>\w+)(?=(?:[^|]*\|){3}\s*\b(?<value>[0-9]+(?:\.[0-9]+)?)\s+(?<unit>[^0-9\s]\S*))/m';
$str = '[1] weight | width | depth | 5.0 kg | 6.0 mm^2 | 10.12 cm^3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);