using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?!\*|\\\*)*?)(\*\\\*)|(\\\*\*)|(\*)|(\\\*)";
string substitution = @"$1${2:+\\\*\*}${3:+\*\\\*}${4:+\\\*}${5:+\*}";
string input = @"*
\*
test
*test*
\*test\*
\\*
\**";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}