import re
regex = re.compile(r"((?!\*|\\\*)*?)(\*\\\*)|(\\\*\*)|(\*)|(\\\*)", flags=re.MULTILINE)
test_str = ("*\n"
"\\*\n"
"test\n"
"*test*\n"
"\\*test\\*\n"
"\\\\*\n"
"\\**")
subst = "$1${2:+\\\\\\*\\*}${3:+\\*\\\\\\*}${4:+\\\\\\*}${5:+\\*}"
result = regex.sub(subst, test_str)
if result:
print(result)