# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\s\S].*?)(\d+)/$2\n/gm;t' <<< "Some random text --- e-1-e-20-e-3"