re = /([\s\S].*?)(\d+)/m
str = 'Some random text --- e-1-e-20-e-3'
subst = '$2\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result