package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\s\S].*?)(\d+)`)
var str = `Some random text --- e-1-e-20-e-3`
var substitution = "$2\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}