import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\*].+?SemprePresente1=(\\d\\d\\/\\d\\d\\d\\d).+?SemprePresente2=(\\d{6}).+?((?:Opcional=)[\\d,]+)?[^\\*]+";
final String string = "********************\n"
+ "SemprePresente1=09/2019\n"
+ "SemprePresente2=987456\n"
+ "Um monte de coisas \n"
+ "Que não preciso\n"
+ "Opcional=698,00\n"
+ "Mais coisas que não preciso\n"
+ "********************\n"
+ "SemprePresente1=06/2019\n"
+ "SemprePresente2=123658\n"
+ "Um monte de coisas \n"
+ "Que não preciso\n"
+ "********************\n"
+ "SemprePresente1=09/2019\n"
+ "SemprePresente2=987699\n"
+ "Um monte de coisas\n"
+ "Opcional=9999,00\n"
+ "Mais coisas que não preciso";
final String subst = "\\1;\\2;\\3\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}