const regex = /^[\*].+?SemprePresente1=(\d\d\/\d\d\d\d).+?SemprePresente2=(\d{6}).+?((?:Opcional=)[\d,]+)?[^\*]+/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\*].+?SemprePresente1=(\\d\\d\\\/\\d\\d\\d\\d).+?SemprePresente2=(\\d{6}).+?((?:Opcional=)[\\d,]+)?[^\\*]+', 'gms')
const str = `********************
SemprePresente1=09/2019
SemprePresente2=987456
Um monte de coisas
Que não preciso
Opcional=698,00
Mais coisas que não preciso
********************
SemprePresente1=06/2019
SemprePresente2=123658
Um monte de coisas
Que não preciso
********************
SemprePresente1=09/2019
SemprePresente2=987699
Um monte de coisas
Opcional=9999,00
Mais coisas que não preciso`;
const subst = `\1;\2;\3\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);