import re
regex = re.compile(r"^[\*].+?SemprePresente1=(\d\d\/\d\d\d\d).+?SemprePresente2=(\d{6}).+?((?:Opcional=)[\d,]+)?[^\*]+", flags=re.MULTILINE | re.DOTALL)
test_str = ("********************\n"
"SemprePresente1=09/2019\n"
"SemprePresente2=987456\n"
"Um monte de coisas \n"
"Que não preciso\n"
"Opcional=698,00\n"
"Mais coisas que não preciso\n"
"********************\n"
"SemprePresente1=06/2019\n"
"SemprePresente2=123658\n"
"Um monte de coisas \n"
"Que não preciso\n"
"********************\n"
"SemprePresente1=09/2019\n"
"SemprePresente2=987699\n"
"Um monte de coisas\n"
"Opcional=9999,00\n"
"Mais coisas que não preciso")
subst = "\\1;\\2;\\3\\n"
result = regex.sub(subst, test_str)
if result:
print(result)