use strict;
my $str = '********************
SemprePresente1=09/2019
SemprePresente2=987456
Um monte de coisas
Que não preciso
Opcional=698,00
Mais coisas que não preciso
********************
SemprePresente1=06/2019
SemprePresente2=123658
Um monte de coisas
Que não preciso
********************
SemprePresente1=09/2019
SemprePresente2=987699
Um monte de coisas
Opcional=9999,00
Mais coisas que não preciso';
my $regex = qr/^[\*].+?SemprePresente1=(\d\d\/\d\d\d\d).+?SemprePresente2=(\d{6}).+?((?:Opcional=)[\d,]+)?[^\*]+/msp;
my $subst = '\\1;\\2;\\3\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";