using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w+)= (\w+).*$";
string input = @"com= com5 # serial port configuration
baud= 9600 # baudrate
# Config Default 04/07/2018
init 3 #";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}