package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w+)= (\w+).*$`)
var str = `com= com5 # serial port configuration
baud= 9600 # baudrate
# Config Default 04/07/2018
init 3 #`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}