$re = '/^(\w+)= (\w+).*$/m';
$str = 'com= com5 # serial port configuration
baud= 9600 # baudrate
# Config Default 04/07/2018
init 3 #';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);