re = /^(\w+)= (\w+).*$/m
str = 'com= com5 # serial port configuration
baud= 9600 # baudrate
# Config Default 04/07/2018
init 3 #'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end