package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\w\s\/\.\p{L}\p{N}\p{S}\p{P}]+`)
var str = `/v1/AUTH_sme/stepan/Folders_pack/03 with special characters ~\`!@#$%^&()_+-={}[];',._over_PHP.zzz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}