$re = '/[\w\s\/\.\p{L}\p{N}\p{S}\p{P}]+/';
$str = '/v1/AUTH_sme/stepan/Folders_pack/03 with special characters ~`!@#$%^&()_+-={}[];\',._over_PHP.zzz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);