const regex = /[\w\s\/\.\p{L}\p{N}\p{S}\p{P}]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\w\\s\\\/\\.\\p{L}\\p{N}\\p{S}\\p{P}]+', 'g')
const str = `/v1/AUTH_sme/stepan/Folders_pack/03 with special characters ~\`!@#\$%^&()_+-={}[];',._over_PHP.zzz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}