re = /[\w\s\/\.\p{L}\p{N}\p{S}\p{P}]+/
str = '/v1/AUTH_sme/stepan/Folders_pack/03 with special characters ~`!@#$%^&()_+-={}[];\',._over_PHP.zzz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end