#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([A-Z ]+) ([A-Za-z ]+) (?:([M]{1}|1\/[2|4|8|16]) )?([0-9]+) ([0-9]+)"
Local $sString = "DUPONT Pierre 1 10 " & @CRLF & _
"DUPRES Paul M 3 40 " & @CRLF & _
"TOTO Titi 1/2 4 60 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")