using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z ]+) ([A-Za-z ]+) (?:([M]{1}|1\/[2|4|8|16]) )?([0-9]+) ([0-9]+)";
string input = @"DUPONT Pierre 1 10
DUPRES Paul M 3 40
TOTO Titi 1/2 4 60 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}