import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z ]+) ([A-Za-z ]+) (?:([M]{1}|1\\/[2|4|8|16]) )?([0-9]+) ([0-9]+)";
final String string = "DUPONT Pierre 1 10 \n"
+ "DUPRES Paul M 3 40 \n"
+ "TOTO Titi 1/2 4 60 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}