$re = '/([A-Z ]+) ([A-Za-z ]+) (?:([M]{1}|1\/[2|4|8|16]) )?([0-9]+) ([0-9]+)/m';
$str = 'DUPONT Pierre 1 10
DUPRES Paul M 3 40
TOTO Titi 1/2 4 60 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);