import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<ul>.*?<\\/ul>)";
final String string = "\"soupp\\n\\nWhat a bloody nice video!! :)) {{youtube:hyYnAioXOqQ}}\\n\\nSuppp\\n\\n<ul>\\n<li>1\\n</li>\\n<li><b>2</b>\\n</li>\\n</ul>\\n{{attachment:2938222}}\\n\\n<ul>\\n<li>1\\n</li>\\n<li>2\\n</li>\\n</ul>\\n<ol>\\n<li>bruhh\\n</li>\\n<li>twotwo\\n</li>\\n</ol>\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}