re = /(<ul>.*?<\/ul>)/i
str = '"soupp\\n\\nWhat a bloody nice video!! :)) {{youtube:hyYnAioXOqQ}}\\n\\nSuppp\\n\\n<ul>\\n<li>1\\n</li>\\n<li><b>2</b>\\n</li>\\n</ul>\\n{{attachment:2938222}}\\n\\n<ul>\\n<li>1\\n</li>\\n<li>2\\n</li>\\n</ul>\\n<ol>\\n<li>bruhh\\n</li>\\n<li>twotwo\\n</li>\\n</ol>"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end