use strict;
my $str = '"soupp\\n\\nWhat a bloody nice video!! :)) {{youtube:hyYnAioXOqQ}}\\n\\nSuppp\\n\\n<ul>\\n<li>1\\n</li>\\n<li><b>2</b>\\n</li>\\n</ul>\\n{{attachment:2938222}}\\n\\n<ul>\\n<li>1\\n</li>\\n<li>2\\n</li>\\n</ul>\\n<ol>\\n<li>bruhh\\n</li>\\n<li>twotwo\\n</li>\\n</ol>"
';
my $regex = qr/(<ul>.*?<\/ul>)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}