// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(<ul>.*?<\/ul>)").unwrap();
let string = "\"soupp\\n\\nWhat a bloody nice video!! :)) {{youtube:hyYnAioXOqQ}}\\n\\nSuppp\\n\\n<ul>\\n<li>1\\n</li>\\n<li><b>2</b>\\n</li>\\n</ul>\\n{{attachment:2938222}}\\n\\n<ul>\\n<li>1\\n</li>\\n<li>2\\n</li>\\n</ul>\\n<ol>\\n<li>bruhh\\n</li>\\n<li>twotwo\\n</li>\\n</ol>\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}