#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(\/[\w-]+)+(\.[\w-]+)+$"
Local $sString = "/root.file" & @CRLF & _
"/nested/file.ext" & @CRLF & _
"/allows-hyphen/file-hyphen.md5" & @CRLF & _
"/allows_underscore/file_underscore.xxx" & @CRLF & _
"/wont_match" & @CRLF & _
"/wont_match." & @CRLF & _
"/wont_match/wont_match." & @CRLF & _
"/wont_match_double_slashes//asasa/xxx.aaa" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")