import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\/[\\w-]+)+(\\.[\\w-]+)+$";
final String string = "/root.file\n"
+ "/nested/file.ext\n"
+ "/allows-hyphen/file-hyphen.md5\n"
+ "/allows_underscore/file_underscore.xxx\n"
+ "/wont_match\n"
+ "/wont_match.\n"
+ "/wont_match/wont_match.\n"
+ "/wont_match_double_slashes//asasa/xxx.aaa\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}