re = /^(\/[\w-]+)+(\.[\w-]+)+$/mi
str = '/root.file
/nested/file.ext
/allows-hyphen/file-hyphen.md5
/allows_underscore/file_underscore.xxx
/wont_match
/wont_match.
/wont_match/wont_match.
/wont_match_double_slashes//asasa/xxx.aaa
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end